Release Candidate 14 (2011-11-12)

Moderators: GSH, Ultraken

Post Reply
User avatar
Ultraken
Patch Creator
Posts: 373
Joined: Fri Feb 18, 2011 6:06 pm
Contact:

Release Candidate 14 (2011-11-12)

Post by Ultraken » Sun Nov 13, 2011 6:19 am

It seems I've fallen back into the old once-a-week schedule... :|


Downloads:

Testing Executable and Symbols
Game Assets (updated 2011-10-13)


What's New

* Increased size of SeismicWave height offset buffer to fix a memory overwrite
- This may fix some random crashes
- I'm surprised the memory checker didn't catch it...

* Pathing system allows off-map paths like 1.4
- This fixes several Instant Action maps that rely on 1.4 behavior

* Fixed ally/unally staying visible after entering invalid input

* Pilots use a new "glide" task to reach empty vehicles close to the Barracks
- They use a course-correcting approach very similar to airborne PowerUps
- They returns to normal "goto" behavior on leaving the building footprint
- TO DO: clean this up a bit

Rocket3497
Drunken Scav
Posts: 10
Joined: Tue Jun 14, 2011 12:56 am

Re: Release Candidate 14 (2011-11-12)

Post by Rocket3497 » Sun Nov 13, 2011 9:34 pm

I downloaded the newest patch and I was sure to get absolutely every file for the patch.

List of files I downloaded and installed:

anet2_vc2008.7z
bzint_2011-11-12.7z
bzone_addon_2011-10-13.7z
bzone16l.7z
dxwebsetup.exe
input.map
label_2011-09-01.7z
net.ini
render.cfg
servers.7z
vcredist_x86.exe
xbox.std

And I did Extract/Install all these files properly.

I also did this step which fixed all the animation movies in the menu
---------------------------------------------------------------------------------------------------------
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
"vidc.iv31"="ir32_32.dll"
"vidc.iv32"="ir32_32.dll"
"vidc.iv41"="ir41_32.dll"
"vidc.iv50"="ir50_32.dll"
---------------------------------------------------------------------------------------------------------

My in game result, however, was worse than it was before:

http://img197.imageshack.us/img197/9646/bz1pic.png

At least with my previous installation, everything had textures and I could walk around without thousands of errors popping up.

Am I missing something?
Please help!

User avatar
Ultraken
Patch Creator
Posts: 373
Joined: Fri Feb 18, 2011 6:06 pm
Contact:

Re: Release Candidate 14 (2011-11-12)

Post by Ultraken » Mon Nov 14, 2011 3:32 am

I should have documented this better but 1.5 requires the official 1.4 patch and large asset pack. The bzone16l.7z I supplied only contains a replacement for the broken bzone16l.zix, not the bzhw16l.zfs that contains all the textures. The proper version is about 3.4MB as opposed to the 4KB placeholder that comes with the retail install. Without it, the game will throw a bunch of warnings about missing textures.

Rocket3497
Drunken Scav
Posts: 10
Joined: Tue Jun 14, 2011 12:56 am

Re: Release Candidate 14 (2011-11-12)

Post by Rocket3497 » Mon Nov 14, 2011 6:33 am

It finally works!

Many thanks for all your help everyone, I can now finally play BZ1 again! :D

Please be sure to include the information about what you said about the 1.4 patch and large asset pack in your future updates to help out the newbies in this patching process. ;)

User avatar
Ultraken
Patch Creator
Posts: 373
Joined: Fri Feb 18, 2011 6:06 pm
Contact:

Re: Release Candidate 14 (2011-11-12)

Post by Ultraken » Tue Nov 15, 2011 8:14 am

I did update the common files topic with that as the first prerequisite.

Once 1.5 is done, I'll consolidate everything into a single installer so this problem won't come up again.

SnakeEye
Rattler
Posts: 93
Joined: Sun Feb 20, 2011 1:05 pm
Location: Åhus, Sweden
Contact:

Re: Release Candidate 14 (2011-11-12)

Post by SnakeEye » Wed Nov 16, 2011 3:49 pm

for some reason there are green or red squares above buldings that are on the map at start, like in the picture below.

Image

Apollo
Sabre
Posts: 456
Joined: Sat Feb 19, 2011 9:51 pm

Re: Release Candidate 14 (2011-11-12)

Post by Apollo » Wed Nov 16, 2011 4:54 pm

That normally occures when the flag is the wrong size.

User avatar
Ultraken
Patch Creator
Posts: 373
Joined: Fri Feb 18, 2011 6:06 pm
Contact:

Re: Release Candidate 14 (2011-11-12)

Post by Ultraken » Wed Nov 16, 2011 10:49 pm

That's the "no flag" flag. Those buildings are on a team but don't actually belong to any player.

Post Reply